Windows add new user problem

Gregor Grob's Avatar

Gregor Grob

10 Aug, 2018 03:34 PM

The windows version will not allow me to add new users. Upon pressing the plus symbol the "add user" window shows up. But no new user is on the list after pressing ok.
I am aware this was a problem for others but the thread is already closed and I am still experiencing this problem.

Some specs:

OS Name: Microsoft Windows 10 Home
OS Version: 10.0.17134 N/A Build 17134
OS Build Type: Multiprocessor Free
System Manufacturer: Hewlett-Packard
System Model: HP Stream Notebook PC 13
System Type: x64-based PC
Processor(s): 1 Processor(s) Installed.
                           [01]: Intel64 Family 6 Model 55 Stepping 8 GenuineIntel ~2159 Mhz
BIOS Version: Insyde F.08, 29-May-15

Thank you for any help!

  1. 1 Posted by Gregor Grob on 10 Aug, 2018 03:38 PM

    Gregor Grob's Avatar

    I also ran the software via cmd with the following result:

    C:\Users\XX\Downloads>java -jar masterpassword-gui.jar
    875             WindowsProvider [INFO ] Starting Windows global hotkey provider
    1578            WindowsProvider [WARN ] Could not register hotkey: HotKey{ctrl meta P}
    Exception in thread "AWT-EventQueue-0" java.lang.UnsatisfiedLinkError: C:\Users\XX\AppData\Local\Temp\mpw7687901413080390065.dll: Can't find dependent libraries
            at java.lang.ClassLoader$NativeLibrary.load(Native Method)
            at java.lang.ClassLoader.loadLibrary0(Unknown Source)
            at java.lang.ClassLoader.loadLibrary(Unknown Source)
            at java.lang.Runtime.load0(Unknown Source)
            at java.lang.System.load(Unknown Source)
            at com.lyndir.masterpassword.impl.Native.load(Native.java:81)
            at com.lyndir.masterpassword.impl.MPAlgorithmV0.<clinit>(MPAlgorithmV0.java:46)
            at com.lyndir.masterpassword.MPAlgorithm$Version.<clinit>(MPAlgorithm.java:209)
            at com.lyndir.masterpassword.model.impl.MPFileUser.<init>(MPFileUser.java:63)
            at com.lyndir.masterpassword.model.impl.MPFileUserManager.add(MPFileUserManager.java:97)
            at com.lyndir.masterpassword.gui.view.UserContentPanel.addUser(UserContentPanel.java:156)
            at com.lyndir.masterpassword.gui.view.UserContentPanel.lambda$new$0(UserContentPanel.java:49)
            at com.lyndir.masterpassword.gui.util.Components$7.actionPerformed(Components.java:283)
            at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
            at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
            at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
            at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
            at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
            at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
            at java.awt.Component.processMouseEvent(Unknown Source)
            at javax.swing.JComponent.processMouseEvent(Unknown Source)
            at java.awt.Component.processEvent(Unknown Source)
            at java.awt.Container.processEvent(Unknown Source)
            at java.awt.Component.dispatchEventImpl(Unknown Source)
            at java.awt.Container.dispatchEventImpl(Unknown Source)
            at java.awt.Component.dispatchEvent(Unknown Source)
            at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
            at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
            at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
            at java.awt.Container.dispatchEventImpl(Unknown Source)
            at java.awt.Window.dispatchEventImpl(Unknown Source)
            at java.awt.Component.dispatchEvent(Unknown Source)
            at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
            at java.awt.EventQueue.access$500(Unknown Source)
            at java.awt.EventQueue$3.run(Unknown Source)
            at java.awt.EventQueue$3.run(Unknown Source)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
            at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
            at java.awt.EventQueue$4.run(Unknown Source)
            at java.awt.EventQueue$4.run(Unknown Source)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
            at java.awt.EventQueue.dispatchEvent(Unknown Source)
            at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
            at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
            at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
            at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
            at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
            at java.awt.EventDispatchThread.run(Unknown Source)
    
  2. 2 Posted by Manuel on 12 Aug, 2018 01:15 PM

    Manuel's Avatar

    Hey MB,

    got the same issue here, too. Same Windows and same build like Gregor.

    Best regards

    Manuel

  3. Support Staff 3 Posted by Maarten Billemo... on 13 Aug, 2018 03:15 AM

    Maarten Billemont's Avatar

    Can you try installing the top download for your OS (x86 or x64, depending on which Windows version you have - or both if you're unsure):
    https://support.microsoft.com/en-ca/help/2977003/the-latest-support...

    Could you also share the output of:

    java -XshowSettings:properties -version
    
  4. 4 Posted by Gregor Grob on 13 Aug, 2018 03:57 PM

    Gregor Grob's Avatar

    Thank you for the quick reply!

    Installing visual C++ did not solve the problem

    Attached the output of the Java version.

  5. Support Staff 5 Posted by Maarten Billemo... on 13 Aug, 2018 04:09 PM

    Maarten Billemont's Avatar

    Thanks, Gregor. For completion, do you mind adding which VC++ redistributables you installed?

  6. Support Staff 6 Posted by Maarten Billemo... on 13 Aug, 2018 04:12 PM

    Maarten Billemont's Avatar

    Also, do you mind trying to update to the latest Java version?

    Currently, the latest JRE for Windows is Java 10 (you have 8):
    http://www.oracle.com/technetwork/java/javase/downloads/jre10-downl...

  7. 7 Posted by Manuel on 13 Aug, 2018 04:33 PM

    Manuel's Avatar

    Here we go! It was the Java Version. My Java did say "There is no update" but there was one... Thanks for helping MB! Next time I'll check Java AND Masterpasswordapp for updates.

    Best regards

    Manuel

  8. 8 Posted by Gregor Grob on 14 Aug, 2018 09:30 PM

    Gregor Grob's Avatar

    Updating Java solved the problem! It works now. Thank you very much for the help.

    Kind regards

    Gregor

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

15 Dec, 2018 10:54 AM
06 Dec, 2018 04:43 AM
05 Dec, 2018 05:24 PM
04 Dec, 2018 01:30 PM
04 Dec, 2018 09:13 AM

 

23 Nov, 2018 04:03 PM
19 Nov, 2018 12:31 PM
17 Nov, 2018 08:16 AM
16 Nov, 2018 01:17 PM
12 Nov, 2018 04:11 PM
04 Nov, 2018 05:56 PM