Press [Enter] to copy the password

Kuno's Avatar


05 Oct, 2014 09:51 AM

I press Enter in the Windows/Java version but nothing is copied to my clipboard. What is the mistake?

  1. 1 Posted by Klaus on 15 Oct, 2014 12:39 PM

    Klaus's Avatar

    On Linux with jdk8 i have a simular problem, if i press enter mpw chrashes. Only if i mrk the password i get it copied

  2. Support Staff 2 Posted by Maarten Billemo... on 31 Dec, 2014 08:00 PM

    Maarten Billemont's Avatar

    Give a try and let me know if it helps?

  3. Maarten Billemont closed this discussion on 31 Dec, 2014 08:00 PM.

  4. Maarten Billemont re-opened this discussion on 01 Jan, 2015 10:41 PM

  5. 3 Posted by bigbang on 07 Jan, 2015 03:29 PM

    bigbang's Avatar

    Same here with me, new version does not help. java --version under linux gives:

    java version "1.7.0_65"
    OpenJDK Runtime Environment (IcedTea 2.5.3) (7u71-2.5.3-0ubuntu0.14.04.1)
    OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)

  6. Support Staff 4 Posted by Maarten Billemo... on 07 Jan, 2015 03:32 PM

    Maarten Billemont's Avatar
  7. 5 Posted by janimal on 08 Jan, 2015 03:25 PM

    janimal's Avatar

    last "SNAPSHOT" runs fine again under:

    Linux with:
    java version "1.8.0_25"
    Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
    Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

    Thanks! :)

  8. 6 Posted by bigbang on 08 Jan, 2015 04:13 PM

    bigbang's Avatar

    Doesn't work for me, either. MPW closes, but no copy in clipboard.

  9. Support Staff 7 Posted by Maarten Billemo... on 08 Jan, 2015 04:48 PM

    Maarten Billemont's Avatar

    @bigbang - the last GIT-SNAPSHOT was reported to work by janimal. Are you having issues with this one?

  10. 8 Posted by bigbang on 09 Jan, 2015 08:12 AM

    bigbang's Avatar

    As i have said: Doesn't work for me. Tried out on second PC with same Java version and the same result.

  11. 9 Posted by Sara on 20 Jan, 2015 04:58 PM

    Sara's Avatar

    I am having the same problem, but no error pops up. It doesn't copy the password at all.

    Windows 8.1.

  12. Support Staff 10 Posted by Maarten Billemo... on 21 Jan, 2015 04:10 PM

    Maarten Billemont's Avatar

    This is still rather a mystery to me. Continuing to look into the issue. For now, the latest Java client will at least allow you to select the password in the field and copy it manually from there with Ctrl-C/Command-C/whatever it is your OS uses.

  13. 11 Posted by Sara on 21 Jan, 2015 08:31 PM

    Sara's Avatar

    Thank you for putting up some kind of fix so it's still usable.

  14. 12 Posted by TT on 11 Oct, 2015 06:22 PM

    TT's Avatar

    I have the same problem (Ubuntu 14.04, Java-Version of masterpassword, Java7).
    The ONLY possible way to copy the pw ist hitting crtl+c. The app crashes if I press Enter. This is acceptable, but the pw should be cleared from the clipboard after a few seconds (like in Keepass).

  15. 13 Posted by Nathan on 07 Mar, 2016 10:46 PM

    Nathan's Avatar

    Same here on Kali 2.0 and
    Debian GNU/Linux 8.3 (jessie)
    java version "1.7.0_95"
    OpenJDK Runtime Environment (IcedTea 2.6.4) (7u95-2.6.4-1~deb8u1)
    OpenJDK 64-Bit Server VM (build 24.95-b01, mixed mode)

    Pressing enter. App crashes. ctl+c works fine

  16. Support Staff 14 Posted by Maarten Billemo... on 08 Mar, 2016 12:40 AM

    Maarten Billemont's Avatar

    What makes you feel the app crashes? If it is really a crash, there should be a stack trace on stdout. Paste it here. The app is designed to quit when you hit enter.

  17. 15 Posted by Jens Grassel on 06 Sep, 2016 07:50 AM

    Jens Grassel's Avatar

    Using the latest released version on FreeBSD and Linux with Java 1.8 I can confirm that the app does not crash. It just closes upon hitting Enter. But the password is not copied to the clipdboard. I circumvent this by using the standard X procedure (select using mouse, pasting using middle mouse button).

    However I find it very inconvenient that the standard behaviour for the app is to close after selecting a password via Enter. When running a password app on a desktop I have usually need for it several times a day or in a row.

    Would it be acceptable to just clear the site information from the app but leave the app open until the user closes it? If yes then I'll have a look at the source and try to write a patch.

    Many thanks for this application by the way. It rocks! :-)



  18. 16 Posted by Sam S on 28 Mar, 2017 05:06 PM

    Sam S's Avatar

    I want to second Jens' request to keep the appl open when copying a pwd.
    To remove the site info is one thing, but the user should not have to re-start the program for every site login. Could the calculator be left open until user shuts it down? Maybe it could automatically switch to the master pwd prompt after a given idle period. I don't enjoy re-typing a pwd over and over, but let's at least eliminate program re-start.

  19. Support Staff 17 Posted by Maarten Billemo... on 28 Mar, 2017 05:08 PM

    Maarten Billemont's Avatar

    The primary reason the app shuts itself down is to restore focus to the previously open application. I certainly don't mind keeping the app open. Perhaps there is even an alternative way to instruct the WM to switch focus from within Java.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

21 Oct, 2018 08:02 PM
20 Oct, 2018 06:47 PM
16 Oct, 2018 11:17 PM
13 Oct, 2018 10:24 AM
10 Oct, 2018 11:48 PM


09 Oct, 2018 01:17 PM
07 Oct, 2018 05:48 PM
05 Oct, 2018 09:22 AM
02 Oct, 2018 10:22 AM
01 Oct, 2018 10:37 AM
30 Sep, 2018 01:07 PM